Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've recently set up a website with a smaller hosting company. The plan has a dedicated IP. They sent me emails to say it's all set up, but now their support channels are all unresponsive even though they say it's open 24 hours.

In the File Manager in the cpanel I've put an index.html file in the public_html directory. But when I point my browser to the IP address given to me, it comes up with the cgi-sys/defaultwebpage.cgi page.

What is the problem?

I haven't set the name-servers for my domain yet, but that shouldn't be a problem because I am using the IP address in the browser.

Note: I don't think I have access to ssh.

share|improve this question
    
[Serverfault][1] [1]: serverfault.com/questions/178427/… check these thread if it helps you. –  Jigar Tank Mar 17 '12 at 9:09
    
The etc folder in my cpanel is empty. –  CJ7 Mar 17 '12 at 9:12
2  
then i think your plan with the comapny isnt't dedicated or VPS. –  Jigar Tank Mar 17 '12 at 9:16
    
They gave me an IP address. –  CJ7 Mar 17 '12 at 10:13
add comment

4 Answers

Unless you plan to use CGI scripts delete the CGI folder entirely, clear your browser cache or view it using the private browsing mode in your browser. You should see your index.html

share|improve this answer
add comment

It's a bit hard to say for sure, but here's what I guess is going on:

  1. Your website is on name-based shared web hosting. You do not have a dedicated IP.

  2. The IP address they gave you is the address of their shared webserver. You're meant to enter it into the DNS settings for your domain.

  3. Since you're trying to access the server using the IP address directly, the server doesn't know which of the sites hosted on it you want. Thus, it's showing you a generic default page instead.

If you want to test things locally before configuring your DNS, you can add it into the hosts file on your own computer, something like this:

111.22.33.44    yourdomain.com www.yourdomain.com

After that, pointing your browser to http://www.yourdomain.com should cause it to request the page from the server at 111.22.33.44, while sending the header Host: www.yourdomain.com to tell the server that it's expecting the content from your domain, rather than from one of the others hosted at that IP.

share|improve this answer
add comment

try editing the .htaccess file... create a .htaccess file if not exists or add "DirectoryIndex index.php index.html" to the existing .htaccess file. i Hope this should solve the problem.

share|improve this answer
add comment

Also, what host? And you can't directly 'load' a site as a ip. You have to use your domain as it requests content as 'yourdomain.com' as it searches for 'yourdomain.com's content. When you type the IP in your address in your browser, it requests it as you Internet Service Provider's nameserver. Ex. Bell Canada DSL gives something like this. 'toronto24.dsa.dsl.bell.ca'. Hope this helped.

share|improve this answer
1  
You can load a site via an IP address, provided the site is configured to work like that. –  paulmorriss Oct 8 '12 at 13:32
add comment

protected by Community Dec 29 '12 at 19:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.