Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I got a new domain http://alfer-ks.com. I have upload files to the server using cPanel, but when I try to load the website, it just shows the cPanel default page, which shows that Apache is running and stuff like that.

What am I doing wrong?

share|improve this question
add comment

2 Answers 2

There is probably an index.html page in the root, most servers look for index.html then index.php then default.html and so on until they find one that works.

Find out what the default page is called by looking in your browser's address bar and delete it from the server along with it's associated files, then the correct page should load.

//Update

It seems you're not alone in having the defaultwebpage.cgi problem credit to @egillette for the fix...

Check your httpd.conf for an entry that looks like this:

<VirtualHost *:80>
    ServerName www.yourdomain.com
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin webmaster@yourdomain.com
    UserDir disable
</VirtualHost>

Change it to (adding your IP in place of XXX. and so on)

<VirtualHost XXX.XX.XXX.XXX:80>
    ServerName www.yourdomain.com
    DocumentRoot /home/yourdom/public_html
    ServerAdmin webmaster@yourdomain.com
    UserDir disable
</VirtualHost>

Then reboot the server and clear your browsers cache

Upload a .htaccess file containing the line

DirectoryIndex index.html index.php

And you should be golden.

share|improve this answer
    
There is no index.html on the root, I deleted it, and I also tried to navigate to a different html file by typing the directory as url, but it returns a 404. –  user1008964 Mar 15 '12 at 20:27
    
@user1008964 what kind of server are you on? –  toomanyairmiles Mar 15 '12 at 20:41
    
I am on a shared hosting server from dotyourdomain.com It uses Apacha and has cpanel. –  user1008964 Mar 15 '12 at 20:45
    
@user1008964 answer updated –  toomanyairmiles Mar 15 '12 at 20:49
    
Where can I find the httpd/conf file ? I can't find the "/usr/local/apache/conf" directory. –  user1008964 Mar 15 '12 at 20:51
show 8 more comments

You should browse your file system and look in your www or public_html folder you can delete the default.html or index.html file that is in there. After you upload your files be sure to clear you browser cache. You should also check that the permissions of the files you are uploading are readable by the server

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.