Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I installed a WAMP package on a Windows 7 machine and everything ( Apache, php, mySql, phpMyAdmin) appear to have installed correctly.

However when I try to access localhost or phpMyAdmin via the browser, I get "Server Not Found". I've tried using localhost, 127.0.0.1 in the browser.

I've checked the httpd file it says "Listen 80". C:\Windows\System32\drivers\etc\hosts says "127.0.0.1 localhost"

Apache log file doen't show any errors.

Suggestions appreciated.

share|improve this question
    
Did you actually start WAMP running? I usually do this by starting a command prompt window, cd'ing into the WAMP directory and then running the program to start WAMP (I think it's wamp_start, but can't confirm at this time as I don't have access to a machine with WAMP installed.) –  GreenMatt Mar 9 '12 at 23:15
    
Have you checked that your hosts file has an entry for localhost? –  Anagio Oct 21 '12 at 9:45
    
3 way solution for WAMP and Skype Conflict. See-> steptoinstall.com/… –  KarSho Jan 6 at 7:30

2 Answers 2

If wamp is running make sure no other program conflict Wamp such as IIS, Microsoft Web Deploy, SQL, Skype, Zonealarm, firewall/antivirus, NOD32, Eset, any web related program including Remote Desktop, Teamviewer ...

IIS and Apache/Wamp are both web server and might conflict in some way, so you have to disable IIS in order for Wamp to work

Disable IIS in Windows Vista/7

  1. Control Panel
  2. Programs and Features
  3. Turn off windows features on or off
  4. Make sure the Internet Information Services is not checked.

Disable IIS in Windows XP

  1. Control Panel
  2. Add and Remove Programs
  3. Add/Remove Windows Components
  4. Make sure the Internet Information Services is not checked.
  5. Restart Computer
  6. (Re)Install Wamp Server

Checking Your Host File

Windows uses a host file to resolve IP addresses, you will need to ensure that noting is conflicting or blocking it running on the local host. Edit this file:

C:\WINDOWS\System32\drivers\etc

Delete anything in this file and have only this line below and nothing else other than

127.0.0.1 localhost

Applications Conflicting on Port 80

Some applications are naughty and decide to run on port 80 one of these programs are Skype. To ensure your chit chat program is not interfering with your WAMP follow these easy steps.

  1. Open Skype
  2. Tools
  3. Options
  4. Advanced
  5. Connection (Uncheck use port 80)
  6. Restart Wamp

Consider Trying Other Ports

Wamp allows you to change the ports that the HTTPD service runs on, you can always try changing the port to see if that works for you. I recommend trying port:8080 and testing localhost:8080 or 127.0.0.1:8080 in your Browser.

share|improve this answer
    
Nice writeup, but use bold for easier reading ;) –  bybe Feb 12 '13 at 20:41

i had simalr problem and suggested answers didn't work for me. then read instructions of installing the application from -wampserver.com.... where it says: warning... you install install Visual C++ 2010 SP1 as shown below.....

WARNING : You must install Visual C++ 2010 SP1 Redistributable Package x86 or x64

VC10 SP1 vcredist_x86.exe 32 bits : http://www.microsoft.com/download/en/details.aspx?id=8328

VC10 SP1 vcredist_x64.exe 64 bits : http://www.microsoft.com/download/en/details.aspx?id=13523

hope this helps..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.