Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a main site, http://hollywoodnose.com and http://forum.hollywoodnose.com. What I was doing was showing the 8 most recent forum posts in the right column of http://hollywoodnose.com. In my Google Webmasters account for the forum subdomain it shows 300+ incoming links fromt the main domain. Obviously it sees every page as in incoming link. Since then my traffic is literally cut in half. I've removed the recent forum posts fromt the main domain and guess I can only wait now.

This seems really odd to me that this would happen. I still have a link in the nav bar of the main domain to the forum and one in the footer. Will the same thing (duplicate links) happen or will I have to remove these two links or possibly set them to rel="nofollow"? Would that make it seem like spam? How do I handle this situation and has anyone ever dealt with something like this? Thank you.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Linking to your forum on every page in your site won't get you into any kind of trouble SEO-wise. That's normal for important parts of a website and site navigation. So don't change this or set them to nofollow (which should never be used for internal links).

I'd be surprised if the most recent forum posts on your home page caused your issue at least as a duplicate content issue. Duplicate content only becomes a problem when it's many page of a website being duplicated. This is just part of one page displaying parts of others.

Have you checked your site analytics to see exactly how your search results were affected? What search terms changed, if any? Have you confirmed it is a search ranking drop and not a loss of traffic from elsewhere?

share|improve this answer
    
forum.hollywoodnose.com shows 329 incoming links from hollywoodnose.com. Since that's been updated traffics gone from 3,900 per day to 1,700. All I did was show the last 8 recent forum posts FROM forum.hollywoodnose.com on the right navigation of hollywoodnose.com. This is the only thing I can link the root of the problem to. I've removed the recent posts and only have a link to forum.hollywoodnose.com in the top nav and footer of hollywoodnose.com. I agree, it's weird and shouldn't be acting that way. But, it is... –  Graham Mar 8 '12 at 2:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.