Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I realize that Godaddy isn't the ideal hosting choice, but I'm running a site on an account with them.

One of the pages on the site, /contactus.php refuses to load. Instead of loading the page, it loads my home page – even though the url displays /contactus.php.

This issue only began to occur when I moved the site from Media Temple to Godaddy (don't ask – it's a weird string of events that led me to do that).

When I run the site on MAMP, /contactus.php loads correctly.

Here is the page on Godaddy (it incorrectly loads the home page): http://aandbinteriors.com/contactus.php/ – and here is a preview of the page on Media Temple that shows how it ought to look http://neilrenicker.com.s140277.gridserver.com/contactus.php/ The fact that it seems to load OK everywhere else makes me think it's an issue at Godaddy, but I'm not sure what!

Any clues, anyone?

share|improve this question
    
Is it possible that some of your redirect rules got screwed up in the migration? –  toomanyairmiles Mar 6 '12 at 16:51
    
It's not a problem with the contactus.php page, it's the trailing slash. If you take off the slash it works. –  paulmorriss Mar 6 '12 at 17:31
    
Thanks for both solving my problem and simultaneously making me feel like an idiot, Paul! Much appreciated, and I'm glad it was a simple fix. I updated the menu link to append the trailing slash, and we're all set. –  Neil Renicker Mar 6 '12 at 17:56

2 Answers 2

up vote 1 down vote accepted

It is the trailing slash that is triggering the issue. Your server is handling non-existent directories by sending them to the home page. You should be getting a 'Page doesn't exist error' instead.

If you are on a linux account, you may want to check you .htaccess settings.

Otherwise I would look into your link structure. Why do you have the trailing slash after your script name?

share|improve this answer
    
This was a site design by someone else, I was just moving the hosting – so I'm not sure why he had a trailing slash in the link structure. I edited that, and we're all set. Thank you SuperMykEl, and many thanks to Paul Morris for originally suggesting that fix. –  Neil Renicker Mar 6 '12 at 18:50

Check to make sure your cases match between the URL and the file itself. contactUs.php is not the same as contactus.php. I've never used MAMP but it's possible that it doesn't care about case; I know that XAMPP under Windows treated URL's as case-insensitive, which caused me some problems when moving to GoDaddy's Linux hosting.

share|improve this answer
    
Thanks Charles. I checked that – no issues there that I can see. Here is the page on Godaddy – it loads the home page: aandbinteriors.com/contactus.php/ – and here is a preview of the page on Media Temple that shows how it ought to look Media Temple preview: aandbinteriors.com/contactus.php/. The fact that it seems to load OK everywhere else makes me think it's an issue at Godaddy, but I'm not sure what! –  Neil Renicker Mar 6 '12 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.