Sign up ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have set up an Edgecast CDN to mirror all my static content. Because I use the root of my domain ( to host my main site—using Google Analytics which sets cookies—I've stored the corresponding static files in a separate cookieless domain ( which is used only for this purpose. I've set it up (using this (mt) guide for general guidance), with the following structure, based on a combination of customer origin and CDN origin to make the most of the chosen short domain name and provide meaningful URLs:

  1. is set as the customer origin for the content stored in the CDN at directory;

  2. I've then set up various subdomains of a separate domain, the conveniently-named, as CDN-origin Edge CNAMEs for each of the corresponding static content types:

    • points to the origin directory;
    • points to the origin directory;
    • points to the origin directory

and so on. This results in some pretty nice, short, clear URLs.

The DNS zone file for (yes, it's a real domain name registered in Djibouti) is set properly:          43200   IN   A      43200   IN   CNAME   43200   IN   CNAME       43200   IN   CNAME

The DNS resolves to the Edgecast URL:

$ host is an alias for is an alias for has address

But whenever I try to fetch a file in any of the directories to which the CNAME assets map, I get a 404:

$ curl
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
<html xmlns="" xml:lang="en" lang="en">
        <title>404 - Not Found</title>
        <h1>404 - Not Found</h1>

despite the fact that the corresponding customer origin file exists:

$ curl

fetches the content of the combined.js file. Yet it's been more than enough time for the DNS to propagate since I set up the CDN.

There's obviously some glaring mistake in the above-described setup, and I'm a bit of a novice with CDNs—but any suggestions would be gratefully received.

share|improve this question

1 Answer 1

Two things I can see here.

  1. You're mapping to This looks correct so far. When you're curling, you're using but when you use the full (which works) you're adding a subdirectory. Did you try ?

  2. CDNs can be a bit tricky in that even if your DNS is correct, they have to have all the right mappings right on their side. There is probably a configuration xml or domain mapping setting on whatever UI you have with then that you should check to verify that even though the DNS resolves, their web servers have the alternate domains as aliases so they actually connect up.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.