Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a Wordpress site on a Debian/Linux dedicated server, with a Backupbuddy plugin for making automatic backups.

The plugin, however, gives an error 'Your server does not support command line ZIP'.

My knowledge of Linux commands is very limited, but I managed installing zip with the command sudo apt-get install zip

However, I still get the same error message. Plugin documentation mentions the problem could also be caused by disabled exec() or safe_mode - but exec isn't disabled, and safe_mode is off.

Any ideas what might be causing this, or how to fix it? The only thing I could think of, is it might be caused by wrong permissions?

share|improve this question
    
try: "yum install zip" and if it still doesn't work - switch to user-root and try again –  alfasin Mar 2 '12 at 19:24
    
thanks for the comment - however, that's not the problem, yum doesn't work, and the command I used results in zip already installed... –  ptriek Mar 3 '12 at 16:11
add comment

closed as off topic by Su', danlefree Feb 16 '13 at 5:34

Questions on Webmasters Stack Exchange are expected to relate to webmastering within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

  • Update BackupBuddy to latest version as there as been some fixes on this issue.

  • Backupbuddy says to do sudo apt-get install zip unzip (in your question you didn't mention that you had unzip install thought you might).

  • Even though you have edited php.ini make sure these rules are being read create a info.php with the following code and point browser to this file.

  • Ensure the zip and unzip is in the PATH environment variable

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.