Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have bought a domain on Crazy Domains called techitproductions.com And at home i have a Linux Ubuntu Server running Apache, php5, ispconfig, courier mail etc... I have port forwarded port 80, 8888 (for ispconfig), 22 (for Putty).

My question is what ports do i need to portforward for a fully working server, with both SSL, SSH and mail working?

My second question is how do i get my domain pointing to my server? My external ip is static.

Please i need a step by step instruction's i am new to Linux servers and the whole website hosting etc...

Thanks, Marais

share|improve this question

1 Answer 1

up vote 2 down vote accepted

My question is what ports do i need to portforward for a fully working server, with both SSL, SSH and mail working?

You need to set up ports 80, 443 (for SSL if you want it), port 22 (SSH/Telnet) and maybe port 21 for FTP if you want that.

Mail:

POP3 - port 110
IMAP - port 143
SMTP - port 25
Secure SMTP (SSMTP) - port 465
Secure IMAP (IMAP4-SSL) - port 585
IMAP4 over SSL (IMAPS) - port 993
Secure POP3 (SSL-POP) - port 995

My second question is how do i get my domain pointing to my server? My external ip is static.

You have to go into your DNS (cloudflare, godaddy, or something) and make an A-record like this:

Host: @ (means 'root domain') Destination: your-ip-address (not another subdomain, it has to be numbers)

You can create subdomains (www, ftp, etc) and just replace the @ with the subdomain you want, and the IP it will go to.

If you haven't done so already, you need to make Apache listen on your domain. Make sure you have this in your httpd.conf file:

NameVirtualHost *:80

<VirtualHost *:80>
<Directory "/path/to/files/">
    AllowOverride All
    Options Indexes FollowSymLinks Includes ExecCGI
    Order allow,deny
    Allow from all
</Directory>
    ServerAdmin your@email.com
    DocumentRoot "/path/to/files/"
    ServerName techitproductions.com
    ServerAlias www.techitproductions.com
    php_admin_value open_basedir /path/to/files/
</VirtualHost>

If you need more assistance, please reply with a comment and I'll try to reply as fast as I can.

share|improve this answer
    
Ok i have portforwared those ports, i have setup my domain to have 2 nameservers (ns1, ns2) both pointing to my external ip. But i still cant visit my server, my apache is listening to port 80 and works on local. –  Codecube Feb 28 '12 at 7:18
    
When I get home from work I will help you out with this (9 hours or so). –  ionFish Feb 28 '12 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.