Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Since Heroku has integrated the piggybank_ssl addon by default, trying:

heroku addons:add piggyback_ssl

or

heroku addons:add ssl:piggyback

results in:

! This add-on is now a standard Heroku platform feature. ! Your apps can already use piggyback SSL.

But, accessing: mywebsite.herokuapp.com results in:

SSL is not enabled mywebsite.herokuapp.com does not have SSL enabled.

My production.rb has:

config.force_ssl = true

What am I missing?

Update

I have read the page SSL on Heroku, but it's obsolete, they suggest to run:

heroku addons:add piggyback_ssl

Which is no longer necessary.

SOLVED !

I don't change anything, and now it's working. It seems that it was a heroku problem.

share|improve this question

migrated from programmers.stackexchange.com Feb 27 '12 at 14:52

This question came from our site for professional programmers interested in conceptual questions about software development.

1  
@Drom: Have you reviewed the help page for SSL on Heroku? –  blunders Feb 27 '12 at 13:44
    
@ Drom: If the question is solved, please post that as the answer so the question is not left unanswered. Thanks! –  blunders Feb 28 '12 at 17:58

1 Answer 1

As a place holder answer until the original poster post an answer stating that after posting the issue that SSL became enabled in Heroku without any know change on their part, and that the issue appears to be a result of some issue on Heroku's end since nothing was change, but the issue went away. See the last update at the bottom of the original poster's question for additional information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.