Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every once in while my Joomla site messes up link's URLs. For example, something like this: http://www.sism.org/index.php?option=com_comprofiler&task=userslist&listid=4&Itemid=123

Become like this: http://www.sism.org/index.php/component/k2/administrator/components/com_dump/assets/css/images/stories/inrilievo/sism/htm/index.php?option=com_comprofiler&task=userslist&listid=4&Itemid=123

The new page has the right content but there's no CSS or other linked resources.

Usually I solve the problem by deleting all the cache and turning it off and on again, which is pretty annoying. Watching the URLs the components involved seem to be K2 and Jdump.

Does any one have any clue on this?

share|improve this question
Actually this time resetting the cache didn't solve the problem!!! Help!!! – Bakaburg Feb 17 '12 at 21:57
i had to turn off cache completely to make it work! but of course it slowed the loading down... – Bakaburg Feb 17 '12 at 22:03
up vote 0 down vote accepted

Possible solution found!

As you could see in the question, the wrong url that joomla generated has com_dump in it.

I unistalled JDump and reset the cache and now it seems to work.

I don't know if this was really the problem or it's still a cache bug and it will reappear in another manner, but for now it works.

I'll keep you updated, but in the mean time i would like some opinion about the problem!


share|improve this answer
Nothing, today, suddenly, it messed up urls again... now it show e.g. this: sism.org/index.php/generale/sism/media/system/… Instead of this: sism.org/… I turned cache off again and it works... Help!!! – Bakaburg Feb 24 '12 at 16:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.