Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

This question already has an answer here:

When I search for mytgp.ph on Google, I don't get any relevant results. But when I search using Yahoo or Bing, the site is the 1st result on the first page. Any ideas?

Here's my site:mytgp.ph query on Google: enter image description here

share|improve this question

marked as duplicate by danlefree Feb 7 '13 at 17:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Comes up just fine for me. If you're logged in to a Google account, what happens if you log out and try the search again? It might just be that your personalized results aren't showing the site or are showing it much further down in the listing, for whatever reason. Have you tried digging a few pages in? –  Su' Feb 3 '12 at 7:57
    
I used another browser to query the site and I am currently not logged into my Google account on that browser (FF). I can't dig in because it is a password protected site and the home page should be enough. –  Ron Feb 3 '12 at 8:03
    
Try running the query 'site:mytgp.ph' perhaps that will work for you? –  toomanyairmiles Feb 3 '12 at 8:17
    
I meant that it might not be showing on the first page of the search results. (When I searched for just "mytgp" rather than the domain, you were pushed to the third page in.) You've got two reports so far that this is just you. Voting to close unless you can provide something else that makes this an actual problem. –  Su' Feb 3 '12 at 8:19
    
I tried site:mytgp.ph and it returns 0 results (Google search) for me. The site has been up since Dec '11 and I even linked it to some of my "older" sites just to give it an extra push. @Su': I wouldn't ask for help here if I saw it a few search pages in since I know it is a relatively new site. I posted it here because my query returns 0 results, which is weird because Yahoo and Bing lists it just fine. –  Ron Feb 3 '12 at 8:34

1 Answer 1

You may have a local problem, I just ran this query and you appear in the first spot.

Google customises your results by country (even by local area in the UK and US, can't speak to other countries) so sign out of your google account, delete all your cookies and cached data and then try again.

You can run a site spesific query using site:mysite.com site:mytgp.ph that should show all the indexed pages of your specific site.

Beyond that sign-up for webmaster tools, which after a period of time should show data about your site's ranking.

Photo of google result

share|improve this answer
    
I ran your query and still no relevant result. :( –  Ron Feb 3 '12 at 8:04
    
I've added a picture to demonstrate. Can you try on your mobile phone, or another computer on a different connection? –  toomanyairmiles Feb 3 '12 at 8:11
    
Thanks for the image. I'll try another device and see how that goes. Could the country i'm in be a factor? –  Ron Feb 3 '12 at 8:22
    
It's possible, you could also try deleting all your cookies, did you see my comment about searching for site:mytgp.ph? –  toomanyairmiles Feb 3 '12 at 8:23
    
Yes, I already tried site:mytgp.ph and I don't get any results. I've been doing this for years and this is the first time Google refuses to index a page (for me anyway). –  Ron Feb 3 '12 at 8:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.