Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

So I did the misstake of using a temporary url a while ago when launching my web site and called it http://web.mysite.com

Now when google indexes it, even that the web. is not the primary url anymore it still uses that over the http://www.mysite.com

Is there any way I can change this? Unfortunately I cant remove the web.mysite.dom binding from IIS since all Google links refer to that and I cannot use wildcard binding on the actual server.

I have google analytics enabled with the correct url (www.mysite.com).

Is there a way to enter some kind of meta data that enforces the robots to see the address as www.mysite.com?

Thanks

share|improve this question
add comment

1 Answer

If you implement google webmaster tools it does give you some options over how the domain is displayed but I don't know if it would help your particular situation.

share|improve this answer
    
Thanks, I've implemented it. I'll get back in a day or two if this solved the problem. –  Eric Herlitz Jan 19 '12 at 9:57
    
Thanks, I'd be interested to know the results –  toomanyairmiles Jan 19 '12 at 10:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.