Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

With things slower during the holidays, I'm taking the time to upgrade out web server account with Media Temple from a dv 3.5 to dv 4.0.

I'm a little out of my element doing this, but have been following this document to get it done: http://kb.mediatemple.net/questions/241/Using+the+Plesk+Migration+Manager#dv_40

Just used the Plesk migration overnight, and it successfully migrated with a few errors.

Unfortunately, I don't know what do do now. I've looked at the errors, and don't see anything alarming. I'm not seeing any of our domains, etc after the migration in our sever.

In the migration manager, I always end up with two migration tasks, with the second never actually starting. Looks like this:

enter image description here

The only difference in the two tasks are the source hostname Any help, tips, etc. would be appreciated.

Just discovered a string of emails that had been held by our spam service:

"Generating new Apache configuration on host failed because the following error(s) occurred:

Syntax error on line 4 of /var/www/vhosts/domain.net/conf/vhost.conf: Wrapper /var/www/vhosts/domain.net/bin/php-cgi cannot be accessed: (2)No such file or directory

Please fix error(s) in templates of Apache configuration and retry generating the configuration file."

How do I enaable php-cgi on the new server?

share|improve this question
1  
Sorry to see that you were running into problems, but glad that you were able to find the answer. Feel free to give us a holler via phones, Twitter, or support request if you run into any more issues. I'll talk to our knowledge base team on getting that info updated into the (mt) KB. –  user12396 Jan 2 '12 at 18:24
    
did you have any issues with your servers relating to root ssh access being disabled by default? (dv 3.5 does not allow direct root ssh access, but 4.0 does). I am getting timeout errors. –  JM4 Jul 25 '12 at 19:14

2 Answers 2

up vote 1 down vote accepted

So I found out that 3.5 > 4.0 migration has issues if your source server is running FastCGI. Disabled FastCGI, and migration went better.

share|improve this answer

A few other notes:

  1. you must have root ssh access enabled on your DV 3.5 for the migration to work as listed
  2. If you have modified the ssh access port, you must change it on the migration page regardless of what MT says.

    When I ran my DV 3.5, we had this disabled and it took quite awhile to realize what the hangups were.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.