Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

The DNS configuration on my website is periodically dropping visitors and I have no idea why.

Most of my website's visitors are seeing it fine, but in the last weeks more and more visitors report that the website isn't loading for them, like the website is down.

My website is www.2mp3.co.il which points to ns1.hosty.co.il and ns2.hosty.co.il (that I've pointed to 109.236.84.71 and 109.236.84.74, and additionally configured it to itself as ns1/2.hosty.co.il)

My server is working with DirectAdmin and centOS - in the DA the NS records for the hosty.co.il domain points to ns1/2.worldstream.nl

What could the problem be?

share|improve this question

migrated from superuser.com Dec 25 '11 at 19:33

This question came from our site for computer enthusiasts and power users.

    
Where are the users accessing the site from? Could it be that their ISP is blocking one of the servers in route. –  kobaltz Dec 25 '11 at 18:52
1  
Have whoever is complaining do a trace route to your server and post that information. –  kobaltz Dec 25 '11 at 18:53
    
I can't ask that from my visitors.. and most of the visits are from Google but it's happens when trying to visit directly also. –  Joe Polico Dec 25 '11 at 19:29
add comment

4 Answers 4

up vote 0 down vote accepted

I've found the problem and fixed it - The nameservers was configured in my server to my 2 IPs, and on the registrar I've configured them in the opposite order to what configured in the server. Thanks for the answers - I would vote up but I cannot do it because I just found out that part of StackExchange.. sorry

share|improve this answer
add comment

I checked manually via dig and all is fine

; <<>> DiG 9.7.3 <<>> @ns1.hosty.co.il www.2mp3.co.il
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 206
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;www.2mp3.co.il.            IN  A

;; ANSWER SECTION:
www.2mp3.co.il.     14400   IN  A   109.236.84.71

;; AUTHORITY SECTION:
2mp3.co.il.     14400   IN  NS  ns1.hosty.co.il.
2mp3.co.il.     14400   IN  NS  ns2.hosty.co.il.

;; ADDITIONAL SECTION:
ns1.hosty.co.il.    14400   IN  A   109.236.84.74
ns2.hosty.co.il.    14400   IN  A   109.236.84.71

;; Query time: 44 msec
;; SERVER: 109.236.84.74#53(109.236.84.74)
;; WHEN: Mon Jan  2 11:02:22 2012
;; MSG SIZE  rcvd: 122

I have double checked with intoDNS and it is fine also http://www.intodns.com/2mp3.co.il

Are you saying that bot NS are on the same server ? (this is dangerous, single point of failure)

What is the error they are seeing ? Can you ask someone to ping your server when it is happening ? Do you have any packet loss when you ping your server for a while ?

share|improve this answer
    
Thanks alot for that response, but I've already fixed it (didn't updated because I needed to wait until the DNS would update, that did happen near the time you answered) - the problem was different configurations on the server and on the registrar –  Joe Polico Jan 2 '12 at 17:48
add comment

I recommend either using your hosting company's nameservers or setting up one on a service dedicated to this. (I have used worldwidedns.net for years and recommend them, it's $10 per year for a single domain and they give you complete control over your DNS.)

It's not a good idea to burden your web server machine with nameserver duties as well, if that is what you're doing.

share|improve this answer
    
Why not? actually I have never heard until now of servers who doesn't host their own nameservers. –  Joe Polico Jan 1 '12 at 21:49
add comment

No host records exist for ns1.hosty.co.il and ns2.hosty.co.il. No wonder the clients have problem resolving www.2mp3.co.il if the authoritative name servers doesn't even exist?!

share|improve this answer
    
How can I define those nameservers? I need to create some record on that domain on the DirectAdmin? –  Joe Polico Jan 1 '12 at 21:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.