Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I'm working on a joomla website, and robots.txt is messing with me... i have it in domain.com/website/robots.txt and I just wanna prevent users from browsing directories.

By default it had Disallow: /images/ and the rule works, can't access the folder. I tried to add Disallow: /images/thumbnails and that one didn't work. I commented out Disallow: /images/ just to test. The folder IS STILL inaccessible. There is no other instance of robots.txt on my domain.

Why are my changes on robots.txt being ignored ? Is there some other file that could override it ?

share|improve this question
add comment

migrated from stackoverflow.com Dec 15 '11 at 17:02

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 7 down vote accepted

The file robots.txt will only work if it is located in the root folder of your web site and not in any sub folder.

Having said that robots.txt is only for search engine robots and has no effect on preventing people browsing folders. If people are able to do that on your server then it is poorly configured and should be set to disallow indexes. This can be done either in an .htaccess file or preferably in the apache httpd.conf file

share|improve this answer
    
Disabled indexes on apache. That's exactly what i needed. Thanks. –  Splint Dec 15 '11 at 21:59
add comment

Robots.txt is not used for preventing users to browse directories. Directory browsing is handled by the web server settings.

All robots.txt does is asking search engines to not index the content within the directories that you specify.

share|improve this answer
    
ok. I think chmod did the job. Thanks. –  Splint Dec 15 '11 at 9:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.