Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Many of our customers are on corporate networks where they have no control over their browser versions, etc.

We have a Wordpress site that doesn't play well with IE8.

We cannot inform the customers to upgrade because they can't.

How should we deal with this?

share|improve this question

migrated from serverfault.com Nov 15 '11 at 19:31

This question came from our site for professional system and network administrators.

12  
IE8 is the current version of Internet Explorer supported on Windows XP, and there's still a lot of Windows XP out there. IE7 and lower is another matter, but IE8 isn't so far back just yet. –  Joel Coehoorn Nov 15 '11 at 18:06
3  
The key phrase is "many of our customers". If you didn't know who your customer was from a technical aspect, how can you develop a web site for them? –  RobW Nov 15 '11 at 18:07
3  
You're so lucky. We're struggling with IE6 support. –  anttiR Nov 15 '11 at 19:19
    
Yes, I KNOW that IE8 is the latest AND LAST version of IE for XP. However, one particular customer is having problems that we cannot reproduce. –  MB34 Nov 15 '11 at 20:08
4  
@MB34 Then the first thing you need to realize before snapping at people is that what you originally asked is an entirely different question than what you just said. This question has been covered by the 15-vote(currently) response. Now you ask a new one, specifying what can't be reproduced, and maybe some people will help you track it down. –  Su' Nov 15 '11 at 22:03

6 Answers 6

up vote 34 down vote accepted

Make your site play well with IE8. Really.

IE8 isn't all that outdated. Unless your site is made solely to cater to them, in which case it should have been made to work with what they have in the first place.

You don't have control over what they run...they don't have control over what they run...but you do have control over what you serve. So the answer seems kind of obvious.

share|improve this answer
    
IE8 is probably the most widely deployed version of IE still and therefore one of the more popular browsers. As far as WordPress and IE8 I've not heard of any issues, but maybe they are specific to your implementation... –  Justin Shin Nov 15 '11 at 17:55
3  
I'd agree with @mfinni's suggestion if the request was something like, "We're running IE 6 and it doesn't work!" but IE8? Like you said, it's WAY too common still to be considered outdated. It's quite unreasonable to expect a company-wide deployment of IE9 for a website now in my opinion. –  Bart Silverstrim Nov 15 '11 at 18:03
2  
IE is the most recent version of Internet Explorer available for Windows XP. Other browser vendors aside for the moment, if you're still running Windows XP, IE8 is as good as it gets. –  Joel Coehoorn Nov 15 '11 at 18:09
1  
+1 If many of your customers can't use your site, this is your problem to fix and not theirs. –  Su' Nov 15 '11 at 19:42
2  
@MB34 then its a terrible theme - any theme designer should be supporting IE8 at an absolute minimum. It supports the standards pretty well. If the theme designer isn't gonna fix it, you'll need to do it yourself. –  DisgruntledGoat Nov 15 '11 at 21:26

This is a product and policy question, not a technical question. However, I deal with a similar situation - we host a website that is based on a vendor's product, and it has a compatibility list. That list is given to our customers as part of their statement of work. If they can't run the browser(s) that we say our site works with, they don't get support for those browsers (or can even choose to not be customers.)

If the customer's company is buying your service, they need to be aware of your compatibility list. This isn't very different from them buying software to run in their own environment - if it requires SQL 2008 but they only have SQL 2005, it's up to them to either try to make it work, upgrade to the supported version, or not buy the product.

share|improve this answer
    
The OP doesn't sound like, from the question as it stands, that they are talking about a bundled product so much as that they have a wordpress site with functions that IE8 doesn't like. I can agree with your reasoning if you had something being hosted or installed that requires something unusual, but they're targeting only IE9 and calling IE8 outdated? Because of a wordpress configuration? Sounds a little stringent to me. –  Bart Silverstrim Nov 15 '11 at 17:57
    
If I hit a bank site that says, for example, I must run IE 9 in order to do web banking, I'm closing my account. I don't even like sites that absolutely require IE alone in order to work. –  Bart Silverstrim Nov 15 '11 at 17:58
    
@Bart, it's probably not a IE9 requirement, but some standards requirement (which IE9 is more compliant than any previous version). Websites I design have this requirement, browsers being mostly standards compliant. –  Chris S Nov 15 '11 at 18:41
    
The problem this particular customer is having happens to be related to a PDF attached to an article. For some reason it locks up his browser. I have tested in my IE8 version and have had no problems. I'm redirecting him to HIS IT dept. –  MB34 Nov 15 '11 at 20:14
    
So the problem isn't with the website, it's with viewing a PDF downloaded from the website? –  Bart Silverstrim Nov 15 '11 at 23:02

One of the best options is to make them install the Chrome Frame plugin: http://code.google.com/chrome/chromeframe/

The benefits are:

  • Your wordpress site will load as if they had Chrome.
  • Other sites, including their corporate tools, will still render in IE8.
  • They won't have to upgrade their browser.

You will need to add a meta tag to your wordpress site. There is also a wordpress plugin to do that: http://wordpress.org/extend/plugins/google-chrome-frame/

share|improve this answer
1  
Can't make them install anything in a corp environment. –  MB34 Nov 18 '11 at 19:37
    
Correct, it's not the employee's responsibility to do it but the admins' of the corporation. It's the healthier option for everyone the rest is just politics. –  Ernest Nov 18 '11 at 19:53

I work for a uni as a web dev and IE8 is a real ball ache! A script I had developed that worked perfectly on my local version of IE8, was messing up on the uni build PC's also on IE8. I could not recreate the problem on my machine, like I saw you said in a comment (sorry not high enough lvl to reply there) then I noticed I was using 8.7.xxxx.xxxxx but the uni machines where running 8.6.xxxx.xxxxx ... the two versions seem to differ a lot ... I'm guessing this may be your problem recreating your erhhh problem, I know this messed me up! You can grab version 8.0 from Old Version. I'm guessing if it works in 8.0 it will work for 8.x.

In answer to your main question, you need to deal with it. IE8 still has a chunky share of the browser market, although IE8 doesn't have any possibility to grow, only shrink, we still need to cater for the users. Web development would be easier for a lot of people if we didn't have to deal with the messed up layouts and ignorance towards established web standards ... but at the end of the day, its competition, the devs on IE do a lot of cool stuff, I just wish they had a 6week update policy like chrome so they can fix the cool stuff that goes wrong!

share|improve this answer
    
Yes, it would be nice if MS$ would come into the 21st century and update their browsers on a regular schedule. However, that being said, this is a corporate environment and they are in control. –  MB34 Nov 18 '11 at 19:38

I know you're asking about IE8, which as many here said - you should support. But let's say you really can't recreate their problem for some reason, you can try what we do when we have to deal with orgs running IE6 internally (you won't believe how many there are in Israel): we make the case to the IT team to allow them to install Firefox and/or Chrome. This often involves begging and pleading (very strategic tactics). In most cases, they allow it and that becomes the browser of choice for our client within the org.

share|improve this answer

Honestly, make your site work with IE 8; it has fairly good support of CSS <3 and JavaScript. If there are some minor issues with IE, use conditional comments. If you're using HTML5, at least use html5shiv, but you should probably use Modernizr, which includes html5shiv.

If your theme doesn't support IE <8, either make a derivative or child theme, or use a different theme. Here's WordPress's official guide to developing a theme.

share|improve this answer
    
To be honest, I don't know if it is the cause of the theme or not. Personally, I think it has something to do with his PDF plugin as noted above. –  MB34 Nov 18 '11 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.