Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

When I try to access index.py in my server root through http://domain/, I get a 403 Forbidden error, but when I can access it through http://domain/index.py. In my server logs it says "Options ExecCGI is off in this directory: /var/www/index.py". However, my httpd.conf entry for that directory is the same as the ones for other directories, and getting to index.py works fine. My permissions are set to 755 for index.py.

I also tried making a php file and naming it index.php, and it works from both domain/ and domain/index.php.

Here is my httpd.conf entry:

<Directory /var/www>
Options Indexes Includes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
AddHandler cgi-script .py
Options +ExecCGI
DirectoryIndex index.html index.php index.py
</Directory>
share|improve this question
add comment

1 Answer

This is probably a silly question, but did you restart your web server process after modifying httpd.conf? Sometimes I forget to do that...

share|improve this answer
    
Oh god... You just saved me a ton of time... :-) –  James Didzun May 11 '12 at 4:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.