Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

DreamHost recently moved my accounts to a new shared box, and now I can't edit files via UltraEdit's built in FTP client, which messes up my work flow!

What did they do that this is not working now? It stopped working after they moved me.

Here's the output from the FTP console in UltraEdit

10/26/2011 10:42:36 AM: 220 DreamHost FTP Server
10/26/2011 10:42:36 AM: USER nodebunny
10/26/2011 10:42:36 AM: 331 Password required for ninjawww
10/26/2011 10:42:36 AM: PASS xxxxxxxx
10/26/2011 10:42:36 AM: 230 User nodebunny logged in
10/26/2011 10:42:36 AM: FEAT
10/26/2011 10:42:36 AM: 211-Features:
 LANG ja-JP.UTF-8;ja-JP;zh-TW;fr-FR;zh-CN;en-US*;bg-BG;ko-KR.UTF-8;ko-KR
 MDTM
 MFMT
 TVFS
 UTF8
 MFF modify;UNIX.group;UNIX.mode;
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 REST STREAM
 SIZE
211 End
10/26/2011 10:42:36 AM: OPTS UTF8 ON
10/26/2011 10:42:36 AM: 200 UTF8 set to on
10/26/2011 10:42:36 AM: PWD
10/26/2011 10:42:36 AM: 257 "/" is the current directory
10/26/2011 10:42:36 AM: PWD
10/26/2011 10:42:36 AM: 257 "/" is the current directory
10/26/2011 10:42:36 AM: CWD /dev/proj/nodebunny
10/26/2011 10:42:36 AM: 250 CWD command successful
10/26/2011 10:42:36 AM: PWD
10/26/2011 10:42:36 AM: 257 "/dev/proj/nodebunny/lib/Buffer" is the current directory
10/26/2011 10:42:36 AM: PWD
10/26/2011 10:42:37 AM: 257 "/dev/proj/nodebunny/lib/Buffer" is the current directory
10/26/2011 10:42:37 AM: TYPE I
10/26/2011 10:42:37 AM: 200 Type set to I
10/26/2011 10:42:37 AM: PORT 10,15,55,125,226,16
10/26/2011 10:42:37 AM: 200 PORT command successful
10/26/2011 10:42:37 AM: STOR Buffer.pm
10/26/2011 10:42:37 AM: 550 Buffer.pm: Overwrite permission denied
share|improve this question

migrated from superuser.com Oct 27 '11 at 3:42

This question came from our site for computer enthusiasts and power users.

3 Answers 3

I have just found a solution to this problem:

  1. Find the following line in /etc/proftpd/proftpd.conf:

Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6 on

  1. Switch this to off

  2. Restart the server

share|improve this answer

As of today, I am still experiencing the same problem with DreamHost FTP. And every time DH support rest FTP server, the problem re-appears after a few hours.

Solution: Use SFTP on port 22. It works for me so far.

Edit: sorry for the confusion, I am not the thread owner. But this is a well known issue among Dreamhost.com users and I just try to post a solution in case someone stumble on this thread from google(like I did).

reference link: http://discussion.dreamhost.com/thread-132172.html

This is the respond I got from dreamhost support:

Hello,

I am so sorry for the problems! I've seen a recurring issue where files cannot be over-written on the server (it doesn't affect new files, just files that are already there).

I have restarted the FTP service on your server and it is working now, but if you see this problem again, please let me know!

Thanks! E- L

share|improve this answer
    
What do you mean "still?" This wasn't originally your question, and as far as I can see this is the first thing you've ever said about it. –  Su' Nov 26 '11 at 10:37
    
nodebunny said "It's fixed now!" in above comment but a lot other Dreamhost users still experience this problem daily. –  Reed Nov 26 '11 at 18:53
    
they had to change the permission settings on the box for me. Ive had to ask them dozens of times over and over ... ultimately its not been fixed for any period of time. –  qodeninja Dec 19 '11 at 2:51

Overwrite permission denied suggests that DreamHost forgot to enable AllowOverwrite on the new server, which means you can't edit existing files, only upload new ones.

To fix it yourself, add the following lines to the .htaccess file in your root directory. You'll have to open the existing .htaccess file if there is one, copy the contents to your clipboard, then delete the file and create a new one with the same contents plus the lines below, because you won't be able to edit the current .htaccess file directly.

<Directory /*>
    AllowOverwrite on
</Directory>

Or you could email DreamHost and ask them to enable AllowOverwrite server-wide. You're probably not the only one having this problem.

share|improve this answer
    
This was a problem on the Dreamhost side, they didnt reset the FTP server. It's fixed now! –  qodeninja Oct 27 '11 at 17:39
    
+1 for brainstorming a solution –  qodeninja Oct 27 '11 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.