Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

My new favicon works in Safari and Chrome, but it's weirdly split in Firefox on Mac or Windows:

Broken favicon

However, if you navigate to the favicon itself it appears fine:

Working favicon in same browser

You can see how it looks in your browser here:

http://coastsider.com

I created the file as a png and later a jpg in Acorn. I converted it to .ico using Graphicconverter. I've also tried converting the png to an ico in other programs.

Has anyone seen this problem before?

share|improve this question
    
Your favicon is OK in 7.01, none changes compared to Safari 5.1.1 –  Lazy Badger Oct 21 '11 at 8:16
    
Not for me in 7.01 on Windows - I see the split. –  paulmorriss Oct 21 '11 at 9:25
add comment

1 Answer 1

There certainly seems to be something funny with the ico file itself IMO. For me, on Windows, it looks broken in Firefox 3.6, Safari 5.1.1 (Windows), does not display at all in Chrome, although does appear OK in IE8 and Opera 11.5. Having saved the file to my HDD, Windows XP does not recognise it as an ICO file (it should display the icon in explorer, but it doesn't).

I can load it in IrfanView OK and resave as an ICO file and it now appears OK!

Icons as they appear in Windows Explorer

You can download the resaved icon from here.

share|improve this answer
    
Good work! The file was probably slightly corrupted. –  paulmorriss Oct 21 '11 at 9:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.