Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a joomla website installed and working good. i installed Qlue404 component which redirects 404 page to a custom page., sometimes when i try the symbols ' and some others the 404 page appears with the message "Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request." also it shows the server information *Apache mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at mywebsite.com Port 80*

how can i disable this message? i swear this leads to get all information for a hacker to do an Sql Injection.

share|improve this question
    
It does not allow "to get all information for a hacker to do an Sql Injection." –  John Conde Oct 11 '11 at 15:33
add comment

1 Answer

From Apache's docs:

Use of ErrorDocument is enabled for .htaccess files when the AllowOverride is set accordingly.

Here are some examples...

ErrorDocument 500 /cgi-bin/crash-recover
ErrorDocument 500 "Sorry, our script crashed. Oh dear"
ErrorDocument 500 http://xxx/

ErrorDocument 404 /Lame_excuses/not_found.html
ErrorDocument 401 /Subscription/how_to_subscribe.html

The syntax is,

ErrorDocument <3-digit-code> where the action can be,

  • Text to be displayed. Prefix the text with a quote ("). Whatever follows the quote is displayed. Note: the (") prefix isn't displayed.

  • An external URL to redirect to.

  • A local URL to redirect to.

Basically what you want to do is place this snippet in a .htaccess file in your root web directory to contain this (obviously you will want to change the URL to one you prefer):

ErrorDocument 404 /my-custom-404-page.html 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.