Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a shared hosting plan where I have hosted my WordPress blog

Now each time I want to access the page I have to type index.php after the domain name.

If I try to access it without using index.php I get 404 error.

Is this because index.php is not added to Default Documents list? Is there anyway I can add the default document list using plex control Panel?

share|improve this question
add comment

2 Answers

Windows hosts sometimes are configured to look for default.htm or index.htm as the default index page instead of index.html.

If you can't find where anywhere to adjust this setting in your control panel, you could change your default index page to default.htm (or just make a temporary file to see if this is the problem) and test it.

share|improve this answer
add comment

Yes, I think that error is because it's not configured to look for index.php.

You should be able to find it under Web Directories -> Preferences (depending on which version of Plesk you have).

share|improve this answer
    
Added the index.php to default documents and moved to top . But still it shows Page Not Found –  Simsons Sep 20 '11 at 16:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.