Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I can't implement MediaWiki on my website. I made a database called soulz_wikipedia. When I configure my wiki, to install it, it asks me what languages etc to choose from, when I press Continue I can't do anything else. All it comes up with is:

MediaWiki 1.17.0 installation

Language
Existing wiki
Welcome to MediaWiki!
Connect to database
Upgrade existing installation
Database settings
Name
Options
Install
Complete!

Restart installation
Welcome to MediaWiki!

Environmental checks
Basic checks are performed to see if this environment is suitable for
MediaWiki installation. You should provide the results of these checks
if you need help during installation.
PHP 5.3.6 is installed.
Unable to determine IP
Backtrace:
0 /home/soulz/public_html/Wiki/includes/User.php(1537): wfGetIP()
1 /home/soulz/public_html/Wiki/includes/db/Database.php(683): User->getName()
2 /home/soulz/public_html/Wiki/includes/db/DatabaseSqlite.php(147): DatabaseBase->query('CREATE VIRTUAL ...', 'DatabaseSqlite:...', true)
3 /home/soulz/public_html/Wiki/includes/installer/Installer.php(636): DatabaseSqlite::getFulltextSearchModule()
4 /home/soulz/public_html/Wiki/includes/installer/Installer.php(387): Installer->envCheckDB()
5 /home/soulz/public_html/Wiki/includes/installer/WebInstallerPage.php(369): Installer->doEnvironmentChecks()
6 /home/soulz/public_html/Wiki/includes/installer/WebInstaller.php(250): WebInstaller_Welcome->execute()
7 /home/soulz/public_html/Wiki/mw-config/index.php(46): WebInstaller->execute(Array)
8 /home/soulz/public_html/Wiki/mw-config/index.php(14): wfInstallerMain()
9 {main}

That's all, I can't install it.. Help?

share|improve this question

migrated from stackoverflow.com Sep 10 '11 at 23:43

This question came from our site for professional and enthusiast programmers.

    
I really don't understand why this doesn't work.. –  user921489 Sep 9 '11 at 18:32
    
"Unable to determine IP" ... sounds clear to me. Something wrong with your setup? –  ckittel Sep 9 '11 at 18:36
    
What do you mean? I set it up accordingly to the guide on installing it. Why won't it work? –  user921489 Sep 9 '11 at 18:38
    
Still having trouble.. –  user921489 Sep 9 '11 at 18:53
    
What is returned when you run the following in a PHP file: <?php var_dump($_SERVER['REMOTE_ADDR']); ?> ..? –  danlefree Sep 11 '11 at 0:06

1 Answer 1

Fix Method 1

Update your MediaWiki to the latest version and this resolves this problem.

Fix Method 2

If you prefer to use an outdated version then this will fix this problem. Edit includes/ProxyTools.php, after line 70 wfGetIP(). After static $ip:

{
$ip = "10.10.10.10";
return $ip;
}

Change 10.10.10.10 to the same IP address of your external internet one. IFCONFIG will reveal this for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.