Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I'm building a store (magento 1.6.0.0-rc2) and have a home server to host the site. It is behind a modem/router with redirection of port 80 and 3000 active to server box.

1. I can access the front-end and back-end from localhost (Slackware Linux).

2. Configured a no-ip account with a host name with 'Port 80 Redirect' enabled. example: store1.no-ip.biz

3. If I try to access the site from another network, I get

Unable to connect

Firefox can't establish a connection to the server at localhost:3000.

A strange thing is that the message returns 'localhost'...

4. but I created a simple index.html file and saved it in the root directory, side by side with index.php, and I can access it without any problem. Permission of these two files are 640, owner myself and group apache (the one httpd runs with).

5. I have no firewall active, hosts.deny is clear.

6. In httpd.conf I have:

<IfModule dir_module>
        DirectoryIndex index.html index.html.var index.php index.php3 index.php4 index.php5
</IfModule>

LoadModule authz_host_module lib/httpd/modules/mod_authz_host.so
LoadModule log_config_module lib/httpd/modules/mod_log_config.so 
LoadModule setenvif_module lib/httpd/modules/mod_setenvif.so 
LoadModule mime_module lib/httpd/modules/mod_mime.so 
LoadModule dir_module lib/httpd/modules/mod_dir.so 
LoadModule alias_module lib/httpd/modules/mod_alias.so 
LoadModule rewrite_module lib/httpd/modules/mod_rewrite.so

Include /etc/httpd/mod_php.conf
Include /etc/httpd/extra/httpd-vhosts.conf

7. In the virtual host I have:

 <VirtualHost *:3000>
    ServerName store1.no-ip.biz
    UseCanonicalName Off
    DocumentRoot "/home/larrobag/lio/apache/magento/"
    ErrorLog "/var/log/httpd/lio_error_log"
    CustomLog "/var/log/httpd/lio-access_log" common
    LimitRequestBody 300000

    <Directory />
            Options FollowSymLinks
        Allow from all
    </Directory>
</VirtualHost>

What am I missing? I'd appreciate any clues on this problem.

share|improve this question
add comment

migrated from webapps.stackexchange.com Aug 23 '11 at 20:36

This question came from our site for power users of web applications.

1 Answer

LazyOne says (pasted from a comment which the original poster indicated solved the problem):

As far as I remember the server name (domain name) used when Magento was installed is used when building/requesting URLs. You do not see it when accessing .html file as it is static file, but you see it when accessing Magento-powered PHP file. Check the Magento settings for localhost and replace all occurrences (except DB and similar) with store1.no-ip.biz. At least this is what I was doing when moving Magento from local to live server when I was using it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.