Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I'm having an issue where I'm submitting my sitemap, too bad I keep this omitted error:

Unsupported file format

Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit.

I followed the sitemap guidelines and error reporting types:

This is what my sitemap looks like:

<?xml version="1.0" encoding="utf-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
  <url>
    <loc>http://mywebsite.com/home</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
  <url>
    <loc>http://mywebsite.com/feedback</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
  <url>
    <loc>http://mywebsite.com/search</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
</urlset>

It seems fine enough, so I re-submitted it and then it returned the same error, that my sitemap is unsupported.

The sitemap has a application header of text/xml if changed to application/xml, it still won't work. What is causing this error?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted
  1. You can validate your sitemap here (if it is not too big): [1], [2], [3] or use any other tool.

  2. I do not see the required <?xml version="1.0" encoding="UTF-8"?> part here -- did you forgot to copy it .. or you do not have it at all? The first link you are referring to has it in the example.

  3. Maybe it is worth adding FULL "header/definition" of the <urlset> -- I have it this way everywhere and never saw any rejections/validation issues:

Your sitemap.xml could be looking like this:

<?xml version="1.0" encoding="utf-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
  <url>
    <loc>http://mywebsite.com/home</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
  <url>
    <loc>http://mywebsite.com/feedback</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
  <url>
    <loc>http://mywebsite.com/search</loc>
    <changefreq>weekly</changefreq>
    <priority>0.2</priority>
  </url>
</urlset>
share|improve this answer
    
Just done everything you labelled down, I didn't forget the <?xml tag. I ran a validation test, both sitemap and sitemap index ran success without any errors. Still getting the same error. –  Burning the Codeigniter Jul 4 '11 at 21:22
    
Hmm.. I just tired the recommended-by-myself validator .. and it validated even non-existed document. Please ignore it and use another tool. I just tested my own sitemap here, here and here -- all fine. Please use your REAL sitemap (with real URLs). Right now I see no reasons why it it should be rejected. –  LazyOne Jul 4 '11 at 21:33
    
Well .. then I guess you need to just wait a day or so .. and resubmit your sitemap again via WebMaster Tools. At the same time you can add this line into your robots.txt -- this will tell everyone who reads and understands robots.txt where to find your sitemap: Sitemap: http://YOUR_WEBSITE/sitemap.xml –  LazyOne Jul 4 '11 at 21:48
    
Okay, I shall do that then. :-) Could you remove the URL please, I have reasons not to keep the link on the page. Thanks. –  Burning the Codeigniter Jul 4 '11 at 21:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.