Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Whenever I try to delete or update any of my tables in phpMyAdmin I receive the following error:

1.import.php: Missing parameter: import_type.


2.tbl-alter.php missing parameters:field

I have looked at the php.ini config file and changed the following settings:

session.save_path ="c:/xampp/tmp" to session.save_path ="C:/xampp/session/data"

Why is phpMyAdmin not letting me delete or update any of the tables within the database?

share|improve this question

migrated from stackoverflow.com Jun 27 '11 at 14:24

This question came from our site for professional and enthusiast programmers.

    
What application is this? –  Michael Jun 27 '11 at 14:08

3 Answers 3

Looks like a corrupted installation of phpmyadmin.

Make sure your permissions are set correctly. Also consider reinstalling phpmyadmin using the latest stable build.

share|improve this answer

I realise this is an old post, but others with the same problem might find the solution useful.

After spending ages with various fixes to session.inc.php I finally had a eureka moment and thought to check the PHP session save directory was correct and writeable. Setting NTFS permissions to Everyone on the folder has fixed it for me.. Doh.

share|improve this answer
    
You have vastly improved my day with this answer. Thank you! –  jerrygarciuh Nov 28 '12 at 19:29

Which OS are you using?

If using windows, try to reinstall your PHPMyAdmin If not using windows, change user permission on your phpmyadmin folder, don't change it to 777 it will return you a error.

share|improve this answer
    
@gerep, I am using windows. –  sareeye Jun 27 '11 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.