Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

So I was developing my PHP application, right? And then all of a sudden, my sessions wont work anymore! So I checked my error log, and here is what it told me (a few times)

PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/imagick.so: cannot open shared object file: No such file or directory in Unknown

Whats going on? I have a regular webhost with access to cPanel. This just happend all of a sudden, and I have no clue of what to do. Help appreciated. :)

share|improve this question

1 Answer 1

Looks like the Imagemagick PHP extension is either uninstalled, corrupted, or moved to a new location. I would send a support ticket to your host with that error message attached and see what they have to say about it. They may have upgraded the PHP installation or the Imagemagick extension and not informed users that it moved.

I'm unsure hwy that is affecting your sessions but it's possible that it causing the rest of the php.ini not to load and thus affecting sessions. It also may be symptomatic of a botched PHP install.

share|improve this answer
    
It just happend all of a sudden. The PHP markup is not visible, hence PHP is "working", however it appears my sessions are screwing up. Everytime I log in to my system (the one I am working on), it generates the above error in the log. –  Jeff Jun 7 '11 at 11:51
    
I had the owner recompile everything, and then it worked. :) –  Jeff Jun 8 '11 at 10:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.