Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have this URL rewrite rule in my .htaccess

RewriteEngine on
RewriteRule ^home$ home.php

but when I try to reach awatag.com/home I get a 404 error.

This rule worked perfectly before moving the domain to GoDaddy.

share|improve this question

migrated from stackoverflow.com May 26 '11 at 18:16

This question came from our site for professional and enthusiast programmers.

    
In this very case you could get away with enabling Options All +MultiViews instead. –  mario May 26 '11 at 17:19

3 Answers 3

Check your old apache config against your new apache config. It might be something as simple as not having mod_rewrite configured on your new server.

share|improve this answer

Try prefixing the redirect path with a leading slash:

RewriteEngine on
RewriteRule ^home$ /home.php [L]
share|improve this answer
    
RewriteRule ^home$ /home.php doesn't work :( –  Aegidius May 26 '11 at 18:21

Adding

RewriteBase /

seems to help some people.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.