Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've placed the Facebook Like button iframe code on my website. When I test it, I receive an error:

"name" likes this. · Error. Clicking on Error gives:

You failed to provide a valid list of administrators. You need to supply the administrators using either a "fb:app_id" meta tag or a "fb:admins" meta tag to specify a comma-delimited list of Facebook users.

If I view the source of the page, I can see:

<meta property="fb:admins" content="529447119" />

What do I need to do to prevent the error? Do you receive the error

share|improve this question
    
No, I don't receive the error. How do I unlike it?! –  paulmorriss May 24 '11 at 7:48
    
I've removed the button, and replaced it with AddThis.com code. –  Steve May 26 '11 at 5:18
    
in my blogs fb like box this error appears "You like this. · Admin Page · Insights · Error" –  user13799 Mar 5 '12 at 7:25
add comment

2 Answers 2

up vote 2 down vote accepted

I've seen a few questions here about similar things in facebook that are resolved once the url is run through the Facebook URL Linter - see if that picks up the admin OpenGraph property.

Next, go to Facebook Insights and 'claim' your site using the green 'Insights for your website' button at the top left. This will use the OpenGraph property to connect your site with your FB account.

Hope that helps!

Adam

share|improve this answer
    
Hi @adam. Thanks, that's excellent help. The linter says: Not CSV. The fb:admins field should be a comma delimited list of Facebook profile IDs (with some whitespace around if you want), i.e. it should match /^\s*[0-9]+(\s*,\s*[0-9]+)*\s*$/. You wrote "steven.doig". What is wrong with what I entered? –  Steve Jun 3 '11 at 4:25
    
Ah, it has to be the id number - you can't use the name. You can find your number through the 'claim' option I mentioned above (I think yours is 529447119). Also, despite what it says, you can only specify one admin id - it won't accept a comma-separated list. –  adam Jun 3 '11 at 7:57
add comment

Two common reasons why this may not work:

  • Your facebook username should be included in a meta tag inside of the html header like so:
<meta property=”fb:admins” content=”FACEBOOK_USER_ID” /> 

Where FACEBOOK_USER_ID is your Facebook username.

  • Set your Facebook username by logging into your facebook account. Go to Account > Account Settings > Settings > Username
share|improve this answer
    
I already have that tag in the source code. I've removed the button, and replaced it with AddThis.com code. –  Steve May 26 '11 at 5:17
add comment

protected by Community Mar 5 '12 at 9:13

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.