Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I unchecked the read permissions for a folder I have on a Godaddy Windows shared host that I want password protected and it worked first time but since going back I get 500 (Internal Server) Error. Thought it might be cache something so tried hard refresh but nothing.

share|improve this question

2 Answers 2

In the GoDaddy Help Center: Password Protecting Web Directories on a Windows Hosting Account

share|improve this answer
    
Been there, done that. Maybe I should have been more explicit in the title. –  Pathfinder May 6 '11 at 13:14
1  
@Pathfinder If you've already followed the host's own instructions(And yes, you should edit your question to point that out.), then it's probably time to talk to support. –  Su' May 6 '11 at 17:05

to password protect a directory on godaddy, don't change the permissions. go to godaddy hosting ftp file manager and select the folder and click on protect. Click on the password protection tab and put a password.

BTW you need an HTACCESS and HTPASSWD file rather than changing permissions. GoDaddy will create it for you when you select the password protection option.

share|improve this answer
    
Thanks for the answer. I remember HTACCESS and HTPASSWD from my linux days. Does Godaddy use them for Windows accounts? I click on folder and do not see a protect option. –  Pathfinder May 1 '11 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.