Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Just looking at logs of a not-so-busy site on one of our Apache servers and notice tons of these in the log:

::1 - - [15/Apr/2011:12:11:40 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Apr/2011:12:11:41 -0700] "OPTIONS * HTTP/1.0" 200 -
::1 - - [15/Apr/2011:12:11:44 -0700] "OPTIONS * HTTP/1.0" 200 -

They seem to appear multiple times just below the GET requests where Apache has served a page & its related images.

  1. what do they mean?
  2. what IP is "::1"?
  3. if they're benign can I suppress them?
share|improve this question
add comment

3 Answers

From here

It's Apache polling its child processes to verify they're responding correctly.

31-2 - 0/0/44 . 0.00 41 0 0.0 0.00 0.92 ::1 mxx1.xx.com OPTIONS * HTTP/1.0

The second field, " - ", shows that this isn't an active connection.. It's the last connection that took place for this particular thread/process. Since Apache polls its children every few minutes it's not unusual to see many of these on a system with light web traffic.

With some versions of Apache you'd see a "GET /" instead of "OPTIONS *" for these connections.

https://issues.apache.org/bugzilla/show_bug.cgi?id=41796

share|improve this answer
    
I see. So, given what you quoted, I guess I could see the value in logging an error when a child process was polled...but as it stands these log entries seem pretty useless. Does anyone know how to suppress them? –  Meltemi Apr 15 '11 at 19:34
add comment

Regarding your second question: ::1 is localhost in ipv6. Regarding your third question:

# Mark requests for the robots.txt file
SetEnvIf Request_Method "^OPTIONS$" dontlog
# Log what remains
CustomLog logs/custom.log common env=!dontlog 

see also http://httpd.apache.org/docs/2.4/logs.html#accesslog

share|improve this answer
add comment

i had this 'problem' and it was annoying as hell. one of two servers i have did this. a year or two later... i just discovered that on one server i has listen 443 in the httpd.conf.

so i put the 'Listen 443' directive in the ssl.conf file.

apachectl graceful

poof... annoying problem gone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.