Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

IE9 renders my web site as IE7. How to make not to make assumptions?

share|improve this question
    
Stupid question I'm sure, but this is happening to just your site, not all sites you visit, right? –  John Catterfeld Apr 11 '11 at 7:57
    
Can you provide the address of your site? –  danlefree Apr 11 '11 at 9:09
    
Depends on the parameter domain name (WTF! o_O). See the spacing above the main buttons/menu and very bottom of the page. And the address. imgur.com/a/qBCdo no problem on the internet but the problem occurs only when i use custom localhost name –  ilhan Apr 11 '11 at 17:52

2 Answers 2

up vote 3 down vote accepted

This meta tag should do it:

<meta http-equiv="X-UA-Compatible" value="IE=9">

You can also send it out as an HTTP header

share|improve this answer
    
when i press f12 i see user ager ie9 and document ie7. i'm setting it to ie9 but when i restart ie, it says ie7 again. the meta tag did not helped at all. –  ilhan Apr 11 '11 at 5:45
    
Depends on the parameter domain name (WTF! o_O). See the spacing above the main buttons/menu and very bottom of the page. And the address. imgur.com/a/qBCdo no problem on the internet but the problem occurs only when i use custom localhost name. thus, now i'm using only the IP address. –  ilhan Apr 11 '11 at 17:53
    
By the way I think I found better one <meta http-equiv="X-UA-Compatible" value="edge"> –  ilhan Apr 11 '11 at 17:57

Probably you are using and incorrect/malformed doctype tag. This is the usual trigger for this behavior.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.