Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am doing some updates to a 10-year old site, and I am baffled. Everything worked great locally, so I uploaded a bunch of stuff to the server using Filezilla. Within Filezilla I can see all of the files, but for some reason I get a 404 when trying to view them.

It seems as though (at least for the folder I'm currently checking) this is happening for items which are "farther down the list" alphabetically. I tried to re-upload a file individually but it didn't change anything.

Is this an indication that I hit some sort of limit with the hosting company? And if so why can I still view the files from Filezilla?

share|improve this question
One thing work checking is if you've got the case exactly right. Non-Windows servers are very often case sensitive. – paulmorriss Mar 17 '11 at 15:14
up vote 2 down vote accepted

Firstly, can you upload a unique file to the root dir and then check on the internet that it is there. Just wondering if you have for some reason connected to the wrong area/account. Have done this myself before.

Also, can you clear the whole directory and then upload one of the "non-working" files and test?

Or create a sub directory and upload to that, testing one file at a time.

Give us a list of the file names & directories, and a url we can test?

Also as Paulmorriss says, check the file name case as non windows servers are a bit fussy about this. You have F5'd/refreshed Filezilla to double check the directory does contain these files

share|improve this answer
I will try the unique file / subdirectory ideas out. The directory is ercolehome.com/images/products/mirrors one specific file: ercolehome.com/images/products/mirrors/SM36_3M.jpg I thought of case sensitivity, and checked and double checked, refreshed and double refreshed. Not the problem. – Zach Lysobey Mar 17 '11 at 15:33
just added: ercolehome.com/images/products/mirrors/wtf.txt and that works... – Zach Lysobey Mar 17 '11 at 15:35
Change the .jpg to .JPG in the URL and it works – Digital Essence Mar 17 '11 at 15:43
Hahahah, i sorted it out... Im sorry to bother you guys. It WAS a case issue (with the file extension). jpg != JPG. I could swear I checked that several times – Zach Lysobey Mar 17 '11 at 15:44
Good news. Helps to explain it to someone else and through this process you spot where it is going wrong. – Digital Essence Mar 17 '11 at 15:57

I found the answer with the SM36_3M.jpg file, you need to make sure the extension is uppercase: http://ercolehome.com/images/products/mirrors/SM36_3M.JPG

The way I found this out was by going to here


You might want to turn off directory listing.

share|improve this answer

That's because all the files can be upload but viewing the file in the internet is not allowed. There are certain restriction that prohibits anyone to see the file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.