Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I'm using magento 1.4.0 and when I try to get to magento connect and download a plugin the page will say

Error: Please check for sufficient write file permissions

Your Magento folder does not have sufficient write permissions, which this web based downloader requires.

If you wish to proceed downloading Magento packages online, please set all Magento folders to have writable permission for the web server user (example: apache) and press the "Refresh" button to try again.

does anyone know how I can fix this problem,

thanks

Update: the plugin I'm trying to use is MagentoPycho light box so I unpacked the folder into the app/code/local but it still doesn't show in the admin area

share|improve this question
add comment

migrated from stackoverflow.com Mar 17 '11 at 13:46

This question came from our site for professional and enthusiast programmers.

3 Answers

Magento installation requires app/etc/ folder writable so it can create local.xml file in there.

For just running Magento - only media/ and var/ folders need to be writable recursively.

If you wish to use MagentoConnect downloader, which is required when using smaller downloader package, you will need to have all Magento folders writable for web service (apache)

share|improve this answer
add comment

In order to use Magento Connect GUI, the web server must be given permission to overwrite ALL FILES AND FOLDERS in the Magento install directory. Magento Connect Permissions This is accomplished by temporarily setting file/folder permissions to the evil 777, running the install process and then resetting the permissions to safe settings. Resetting Magento File Permissions

Having to mess with file/folder permissions can be avoided by using pear in an SSH session from the command line to perform Magento Connect installs. Use Pear to download and install Magento Connect extensions

share|improve this answer
add comment

Magento prior to version 1.5 required complete access to the file system (after 1.5 an FTP client was introduced that allowed Connect access to the file system via ftp)

You can do 3 things

  1. as above, set all files to 777. This is a pain and you will have to reset them all after. If you have Aitoc or similar modules you will have to then track down which files need extra permissions

  2. change the file ownership of all files to apache (or what ever your web server runs as). This is less hassle and keeps your file permissions as they were. Simply revert ownership back after the install.

  3. Change how php runs on your server. It sounds like Apache is running as mod_php. Change this to fast-cgi and all files owned by you will be accessible to the server. Switch back afterwards to continue the benefits of mod_php

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.