Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Is there a special port for godaddy servers? Do I have to call them to enable ftp support? I can login w the username and password on the control panel on godaddy.com but not on ftp. I'm not sure what I'm doing wrong. I tried using Filezilla and CuteFTP Pro using port 21 but w/ no luck.

Go Daddy's Instructions are:

  1. FTP Address or Hostname: Your Domain Name
  2. FTP Username & Password: You selected both of these during account creation
  3. Start Directory: You should leave this blank or include a single forward slash (i.e. /)
  4. FTP Port: You should enter Standard, or 21. •FTP Client. ( ◦Filezilla, ◦WS-FTP, ◦CuteFTP Pro, ◦AceFTP )

Thanks!

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

Are you following godaddy's FTP instructions?

Update

Try setting data connection type to PASV (passive mode)

share|improve this answer
    
Thanks for your reply. Yep, I have the ftp set on port 21... –  Brian McCarthy Mar 9 '11 at 15:27
    
@Brian, updated my answer with my next guess. :) –  John Conde Mar 9 '11 at 15:30
add comment

What do the FTP client logs/terminal show in terms of errors?

In Filezilla -> View -> Message Log you will see the command/response sequence when your client attempts to login. You should be able to work out where it is going wrong from the codes.

EDIT: Wikipedia has a list of the common FTP codes

share|improve this answer
add comment

1) May sound stupid but did you put in ftp.yourdomain.com in for host? Try that if you didn't already.

2) Did you setup an actual FTP Account? Check here:

Hosting Dashboard > Settings > FTP Users

Create another user other than the "Primary FTP User", as that is typically your regular login info to the site. Once created, wait a few minutes till it says it's completed the setup, then go to your FTP Client and type in host: ftp.yourwebsite.com and the username with password, on port 21. You should be set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.